IonCube Loader is a software tool, that is needed to run files that are encoded with ionCube PHP Encoder. The latter is an app which is used to make PHP code human unreadable, so as to protect it from reverse engineering and illegal use. Plenty of script-driven apps, particularly online forums, cms and electronic commerce solutions are protected with ionCube PHP Encoder, so when you acquire a script and you find that ionCube is on the list of web hosting environment prerequisites, you have to make sure that your website hosting server has the tool pre-installed. While it is not that difficult to install it when you have your own server, it's almost impossible to do that on a shared hosting server because the PHP environment should be precompiled and all the clients on the server shall be affected.
IonCube in Shared Website Hosting
When you obtain a shared website hosting package from our company, it will be created on our custom cloud platform where ionCube Loader is already present, so you won't have any kind of problems to manage any script application which requires the tool to function appropriately. Furthermore, we offer you several different versions of PHP, which means that in case you change the version, you will have to enable ionCube again. Our system remembers the adjustments you make, and when you move back to the previous release of PHP which was active for your account, ionCube Loader will already be turned on. The PHP version and the ionCube tool can be operated through the PHP Configuration part of our Hepsia web hosting Control Panel. Every change that you do takes literally just a single click and it'll take effect instantly.
IonCube in Semi-dedicated Hosting
If you get a semi-dedicated server package from our company, you'll be able to use any kind of script-driven application which requires ionCube Loader for the reason that the software tool is installed on all of the servers which are part of our revolutionary cloud web hosting platform. Furthermore, we support several versions of PHP, therefore if you move from PHP 4 to 5.2 or 5.3, for instance, you can enable ionCube for this particular release with only a click in your Hepsia Control Panel. Our system will remember your choice, and in case you move back to the previous version of PHP, the instrument will already be active. For more tech-savvy users, we also offer the option to choose the PHP version and whether ionCube will be active or not for a particular domain without altering the settings for the whole website hosting account. This can be done by putting a php.ini file within a domain folder with several lines of code.